Jump to content
Sign in to follow this  
Chewett

Artifact Error

Recommended Posts

The artifact at beserkers upon completion says "The artefact you are trying to load was not found, please refresh the interface and try again"

You then close it and click on the artifact and you get the correct message.

Should be fixed

note: im sure there is another topic, i just cant find it currently

Share this post


Link to post
Share on other sites

yes, pretty much every time an alt of mine goes through solving the contraption.
I refresh, and only after doing so get the white and wince as my speakers blow up. :)

I'll send another alt through there later this week if no one else confirms/denies it. (both in Firefox and IE8 if I recall correctly)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Forum Statistics

    15,915
    Total Topics
    174,101
    Total Posts
  • Recently Browsing

    No registered users viewing this page.

  • Upcoming Events

    No upcoming events found
  • Recent Event Reviews

×
×
  • Create New...